サポート > 機能更新履歴(機能追加・障害報告) > Ver.7.701〜Ver.7.719
 機能更新履歴(機能追加・障害報告)_Ver.7.701〜Ver.7.719

Ver.7.701〜Ver.7.719
Ver.7.601〜Ver.7.609
Ver.7.500〜Ver.7.518
Ver.7.401〜Ver.7.459
Ver.7.301〜Ver.7.332
Ver.7.201〜Ver.7.229
Ver.7.001〜Ver.7.103
2019/03/19 [7.719]
  • コマンド:VideoPlay2を追加。
    OpenCVのライブラリを使用して、(IEブラウザではなく)PC-MAPPINGのモジュールとして直接的にビデオとGPSログをリンクして表示する。
    従来は計算フィールドで
    "Command:VideoPlay " & $VideoPath & " " & <経過時間> & " -HtmlBar 11"
    としていたものを
    "Command:VideoPlay2 " & " -t " & <経過時間>
    に置きかえる事で実行される。
    ※PVP(拡張)でも双方向動作可能。
    尚、実行するには別途PC-Mapping VideoPlayモジュール(pcmcv.dllおよび関連DLL)がEXEのフォルダーに必要で、これらは、
    最新版ダウンロード PC-MAPPING Ver.7
    の最下部からダウンロードする必要がある。
    【MAPCOM WORLD TOPICS】動画ファイルとGPSログを使って情報を管理しよう!
  • [編集]-[正規化]-[正規化座標変換]で、「シンボル、注記の回転調整する(ポイント、ノード)」オプションチェックを追加。
    各ノード、ポイント位置での変換前、変換後から想定回転角度を算出して、回転角度型フィールド(があれば)の値を調整する。
  • DB:[編集]-[座標データ]-[座標データの変換]のダイアログボックスを変更。
    経緯度の座標値形式に関して DD:MM.MMMMM 度分 形式に対応した。
    また、経緯度に変換する場合、その形式も選択できるようにした。
  • クイックシェープをレイヤーに変更する際、「メモ」データフィールドはウィンドウ非表示状態としているが、pcm.iniで
    [QShapeToLayer]
    Flags=2

    をセットすることで、この機能を抑制できるようにした。
  • プロジェクトワークスペースの各アイテムフォルダーの開閉状態に関して、pcm.iniで
    [PWS]
    SaveExpand=1

    を設定することで、その情報をプロジェクトファイルに保存して、次回に復元されるようにした。
  • [編集]-[編集作図]-[同一属性要素間アーク作図]で、「最近接の1つのみ作図する」オプションを追加。
  • [属性]-[ポイントからの属性転記]で、「結線アークを生成する」オプションを追加。
  • [ファイル]-[インポート]-[CADデータ交換標準フォーマット(SXF)]において、複数の部分図配置情報があった場合、これらをセットした空のレイヤーを生成し、「部分図配置座標」レイヤーフォルダーに登録されるようにした。
  • [ツール]-[UAVコース]-[UAV飛行計画コース 調整・出力]に関して、明示的に「コース平滑化」(しきい値)を設定できるようにした。
  • ≪試験的機能≫
    コマンド:MpoToAnaglyphを追加。
    MPO画像ファイルを読み込んでアナグリフを生成する。
    【書式】MpoToAnaglyph△-dpx△n△-dirout△(保存先フォルダー)△(MPOパス名)△(MPOパス名)…
    【引数】
    • -dpx△n:2つの画像を重ねるときのオフセットピクセル値(デフォルトは0)。正数で視差が多く、負数で視差は小さくなる
    • -dirout△(保存先フォルダー):生成画像の保存先、省略時はイメージウィンドウとして開く
    • (MPOパス名):開く画像パス名(複数可、省略時はダイアログを開いて指定する)
    • -ToImage:アナグリフではなく、左右の画像を結合した1枚の画像を生成する
  • コマンド:ImageToAnaglyphを追加。
    現在読み込まれている左右の画像を結合したイメージからアナグリフ画像を生成する。

2018/12/27 [7.718]
  • [ツール]-[UAVコース]-[UAV飛行計画コース 調整・出力](コマンド:UAVCourseAr)を追加。
    計画された飛行コースアークを修正・変更した後、(必要あれば)再度高さ調整して出力する。
  • [ツール]-[UAVコース]-[8の字飛行コース作図](コマンド:UAVCourseCalib)を追加。
    IMUのキャリブレーションに使われる8の字形の飛行コースアークを作図する。
    ここでは、高さ情報は設定されないので、必要なコース連結等の調整後、[UAV飛行計画コース 調整・出力]で高さ情報を追加する。
  • クイックシェイプについて、注記(文字列)の作図を行った際に指定した地点の右下固定ではなく、整列位置を指定して配置されるようにした。
  • [ツール]-[UAVコース]-[UAV撮影コース設計(カメラ撮影)]のダイアログで、
    1. 「指定間隔(以内)毎にウェイポイントを配置する」オプションを追加。
      計算上のアークのセグメントが指定値以上になる場合は、補間点(ウェイポイントになる)を追加する。
    2. 「コース間を滑らかにターンする」チェックを追加。
      これがONの場合は、コースからコースへの移動に関して、補間点(ウェイポイントになる)を追加して円弧近似で方向転換する軌道を生成する。
    3. 出力パス、出力パス2、出力パス3、それぞれにチェックボックスを設定し、これがONの場合、パス名が入力されていればファイルに出力し、そうでない場合は、該当レイヤーの生成のみが行われる。
  • [ツール]-[標高メッシュ効果・解析]-[段彩陰影図]で、「余色立体図を生成する」オプションを追加。
  • [ツール]-[空間統計解析]-[ポリゴン包含要素属性検索](コマンド:PolOvrElm)を追加。
  • ポリゴンに包含される要素の指定属性フィールド値を比較して、最大、最小、中間値の要素を選択状態にする。
    尚、アーク、ポリゴンに関してはその代表点が包含されるポリゴンに包含されるものとして扱われる。
  • [設定]-[現在の表示領域のベクトルタイルデータを取得]に
    • 地名情報(居住地名)
    • 地名情報(自然地名)
    • 地名情報(公共施設)
    • 地名情報(住居表示住所)
    • 地形分類(自然地形)
    • 地形分類(人工地形)
    を追加。
  • 描画パラメーターのポイント(ノード)パターン設定で、
    • 「拡張グラフィックス」を使って、「アンチエイリアス」のみなし 
    のオプションを追加。

2018/11/14 [7.717]
  • [ツール]-[UAVコース]-[UAV撮影コース設計(カメラ撮影)]・[ツール]-[UAVコース]-[UAV撮影コース設計(レーザースキャナー)]において、KMLファイル出力オプションとして
    • 出発地点からの相対値(Kml飛行計画モード)
    • 絶対値(Kml確認モード)
    を選択できるようにした。
    通常コントローラーには出発地点からの相対値で渡すが、GoogleEarthなどで視認する際には絶対値で閲覧する。
    また、コース出力用に生成されたレイヤーは従来は、出発点からの相対高度がZ値に記録されていたが、レイヤーとしては絶対高度が設定されるように仕様変更した。
  • [ツール]-[UAVコース]-[UAV撮影コース設計(レーザースキャナー)]において、
    • 計画コースの間隔を指定の一定間隔で設計するモードを追加
    • 90度回転させたコースを同時に生成するオプションを追加
    • 相対高度で斜面を飛行する場合、しきい値(距離m)を指定して、隣接斜面に接近しすぎている箇所を検出するオプションを追加
    また、コース出力用に生成されたレイヤーは従来は、出発点からの相対高度がZ値に記録されていたが、レイヤーとしては絶対高度が設定されるように仕様変更した。
  • [設定]-[領域指定でプロジェクトの切り出し]で、「ポリゴンは「包含関係のみ構造化」レイヤーに変換して切り出す」オプションを追加。
    これがONの場合は、切り出されたポリゴンは再構成される。
    ※矩形の領域で切り出す場合にのみ有効。
  • レイヤーの背景イメージ設定で「(カラー画像を)モノクロに変換して表示」・広域イメージの設定で「モノクロに変換して表示」のオプションを追加。
    いずれも、画像の実体は変更せず、描画時のみモノクロ化して表示する。
  • 輪郭グラデーションでポリゴンを塗りつぶすケースで、複雑な図形であってもポリゴン外部へはみ出さないよう、クリッピング処理を付加した。
  • コマンド:GDIPSetを追加。
    環境設定での拡張グラフィックスのOn/Offを制御する。
  • 正規化コマンド新タイプ:Nrm1を追加。
    コマンドの後ろに半角スペースを区切りとして、パラメーターを記述する。
  • ≪元号の元年表示≫
    ---
    《Ver.7.711》
    Pcm.iniで、
    [PCMDateTime]
    GengoMode=1
    で、日付時刻型の元号表示に関して、Windows認識の元号が表記されるようにした
    ---

    に追加して、
    [PCMDateTime]
    GengoMode1=1

    で「XX1年」を「XX元年」と表記されるようにした。

2018/09/03 [7.716]
  • [ツール]-[空間統計解析]-[ポイントからの放射アーク生成](コマンド:Pnt2Radial)を追加。
    ポイントから図郭線上までの放射状のアークを生成する。
    途中に遮蔽として指定されたアークがある場合は、そこで中断される。
  • [選択]-[選択状態の転記(レイヤー間)]のダイアログボックスで、現在選択されているベクター数を知る上で、ドロップダウンリスト中に (選択数)/(総数) 形式で表記するようにした。
  • [プロジェクトエキスパート]-[属性データベース]パネルのデータベース一覧で、ADO外部リンクデータベースに関しては、パス名表示位置に: "【ADO】(元テーブル名)"を表記するようにした。
  • [ファイル]-[インポート]-[DXF(AutoCad)]において、「ブロックの挿入点にポイントを発生させる」オプションを追加した。
  • [設定]-[タイル形式画像背景表示設定]で、URLの指定方法を拡充して、http://**************/{z}/{x}/{y}.png のような{x} {y} {z} のプレースホルダーを使った表現に対応した。
    これにより地理院タイルのようにzxy方式でフォルダ構成された画像サイト以外のサイトにも対応できる。
    なお、背景プロジェクト設定パネルでの「タイル画像取得、背景描画」は廃止。
  • レイヤーエキスパートのアーク、ノード、ポリゴン、ポイントの各パネルに「縮尺による表示制御」を追加、前景時と背景時それぞれ独立して設定できる。
    レイヤー単位ではなく、レイヤーの要素種別ごとに縮尺表示制御を行う(尚、プロジェクトの表示モードで前景時、背景時の「縮尺表示制御」がONになっていることも必要)。
  • 広域ベクターでPostGISを登録した場合、PC-MAPPINGから空間データへエクスポートする際にPC-MAPPING固有のフィールドのデータ型は文字型等に置き換わって格納されるため、それらを使った描画制御等を行うため、レイヤー側に登録される(同一タイトル) 【INFO】レイヤーを参照し、その方のフィールド型などに合わせて描画設定できるようにした。
  • ランキングフィールドの設定(機能)で、NULL値(空白)を入力データおよび出力データで扱えるようにした。
    設定時に空白の状態で登録することで、NULL値と解釈される。
  • [システム環境設定]-[操作3]パネルに「タッチパネルでのジェスチャー機能」として
    • ズーム機能のみ動作
    • パン(移動)機能のみ動作
    • 回転機能のみ動作
    • プレス and タップをマウス右ボタンシミュレーション
    • 従来の移動モード
    の各チェックボックスを追加(従来pcm.iniファイルで制御していたものを明示的メニュー化した)。

2018/06/12 [7.715]
  • 表示モードの「描画順位」に関して、「地理院地図」と「ラスタータイル」を追加して、描画順位をカスタマイズできるようにした。
  • [ファイル]-[システムツール]-[イメージ変換]-[イメージファイルの図法変換]を追加(コマンド:ImageCoordConv)。
    イメージファイルを開いての「画像の図法変換」と同様だが、イメージファイルを開かずにファイルを指定して変換する。
  • 計算フィールドの指定で、
    • poscode(L, B, H, id):論理場所情報コードを返す
    • $PosCode:ポイント・ノードの内部属性DBの場合その位置の場所情報コード、アーク・ポリゴンの場合代表点(あれば)位置の場所情報コード(屋外)
    を追加。
    いずれも冒頭64ビットの管理組織コードは省略されるので、必要あれば、文字列で"00001B0000000003" & $PosCodeのように記述する(例は国土地理院のコード)。
  • [ツール]-[表示領域検索]-[表示中心付近をMapFanで閲覧]を追加(コマンド:MapFanView)。
    現在の表示領域付近をMapFan(https://mapfan.com/)を開いて閲覧する。
  • [ヘルプ]-[照会・障害の報告]に関して、マプコンSMTPの使用をやめて、httpsでマプコンサーバーに送信する方式に変更した。
  • [システムツール]-[画像処理]-[イメージバンド合成](コマンド:RasterBandMerge)を追加。
    8ビットカラーの画像ファイルを3または4つ指定して、24ビットまたは32ビットカラー画像を合成する。
  • [ツール]-[空間統計解析]-[ポリゴン・イメージオーバーレイ集計]を追加(コマンド:PolRasterOvr)。
    プロジェクトを開いて、ポリゴンのあるレイヤーを前景にした状態で実行し、ダイアログで集計方法を「平均/最小値/最大値/中央値/標準偏差/種類数/総合計」から選択する。
    指定の画像から8ビット(0〜255)・32ビット(単精度実数)として解釈して計算し、結果は指定フィールドに格納される。
  • [設定]-[地理院タイルを広域イメージに登録]において、「経緯度座標に変換する」チェックを追加。
    通常は座標値としては経緯度座標が入るが図法としてはWebメルカトルになっている(縦方向のピクセル値と緯度値は非線形な関係)が、これを経緯度での(単純な)方眼座標に変換する。
  • ADOでのレコード読み込みに関して、pcm.iniで
    [SystemEnvMgr]
    ADOBulk=100

    の記述で、(この場合)100レコード分をまとめて読み込んで処理するバルクモードを追加した。
    このモードで取り込みが高速化できる場合が期待できる。
  • [ファイル]-[エクスポート]-[Webメルカトルタイル画像]に関して、まとめて生成するタイル数を(従来の)1から64(x64版では200)まで指定できるようにした。
    内部的に大きな画像を生成して描画し、それから複数のタイルを切り出すことで高速化が見込まれるが、大きな画像を生成して処理するだけのメモリが必要。
    例) 256X256ピクセルのタイル1枚は、実際には、1024X1024ピクセルの画像からアンチエイリアス処理をして生成される(さらに、周辺マージンもとるので、実際には1280X280ピクセルの画像が用いられる)。
    まとめて100枚のタイルを生成する場合、内部的に10240X10240ピクセル+周辺マージン分の画像メモリが必要で、さらに、作業用の画像メモリ等も要求される。
  • [ファイル]-[エクスポート]-[ベクトル(GeoJSON)タイル]に関して、ポリゴンレイヤーの出力の場合、ポリゴンのクリッピング(図郭部分に仮想線を発生させる)とポリゴンを構成するアークのクリッピング(図郭で単純クリッピング)を分けて実行してGeoJSONファイルに出力されるようにした。
    また、出力の判定に従来のレイヤーの表示・非表示に加えて、レイヤー表示設定の形状(アーク:線形/ポリゴン:フィル/ポイント:点位置)のチェックも評価するオプションを追加した。
  • [ヘルプ]-[最新版の検索]で、通信プロトコルとして「https(セキュア)プロトコルを使用する」オプションを追加。
  • ≪試験的実装≫
    [ツール]-[UAVコース]-[UAV撮影コース設計(カメラ撮影)]のカメラ諸元ダイアログボックスで、「地上解像度を確認するための最長高低差を設定する」オプションを追加。
    この条件に合わないと算出されたポイント(位置、数は計算ピッチに依存する)を「飛行計画(最長高低差エラー箇所)」レイヤーとして生成する。
    ポイント内部属性には、どのコースからのエラー箇所かを記録する。
    一般に、標高が高く、相対的に高い高度のコースからコース直下の標高よりも低い位置がコース範囲に入ってきた場合に、最長高低差が指定値より大きくなってエラー箇所と指摘される。
    ただし、サイドラップ、オーバーラップがあるので、他のコース、写真では許容値に入っている場合もあるので、どう解釈するかの問題もある。

2018/04/10 [7.714]
  • [ファイル]-[エクスポート]-[航空機レーザースキャナ(LIDAR)点群データフォーマット(LAS)](コマンド:ExportLAS)を追加。
  • [プロジェクトエキスパート]-[3Dポイントクラウド]で、LASファイル登録を可能にした。
  • [編集]-[レイヤー]-[注記3DView設定]のダイアログボックスで、「「2D型」描画する」チェックを追加。
    これがONの場合、そのレイヤーの注記に関しては通常の「3D看板型」ではなく、3DView上のその位置に単純に文字列描画される。
    「3D看板型」のように回転したり裏返されることはないが、「陰線」処理されないので、視野上見えないはずの注記もXY面内にあれば描画される。
    なお、この処理は背景レイヤーにのみ適応される。
  • [ファイル]-[システム環境]-[システム環境設定]-「表示と印刷」で、「属性表示の再配置での拡張モード」チェックを追加。
    これがONの場合、従来の属性表示再配置機能を拡張した再配置を行う(デフォルトはON)。
  • [ツール]-[描画パラメーター]-[ポリゴンステップカラーの生成]を追加(コマンド:PolColorBrush)。
    ポリゴンの属性をキーにして、カラーフィールドまたは描画パラメーター(ポリゴンブラシ)を生成する。
    属性値均等割り付けと、ポリゴン数均等割り付けの2つのモードを選択できる。
    ステップ間を按分計算するグラデーションモードも選択できが、ポリゴンブラシを生成する場合は、グラデーションモードは無視される。
  • [設定]-[タイル形式画像背景表示設定]のダイアログボックスに、「KMLネットワークリンク」のボタンを追加。
    指定のKMLからタイル形式の画像情報を取得する。
  • イメージ:[図法変換]-[画像の図法変換]の[投影(図法)変換]ダイアログボックスで、「(アルファ付き)32ビット画像に変換する」チェックを追加。
    これがONの場合は、投影変換でできる周辺の白部に相当する画素のアルファ値を0(透過)とした32ビット画像に変換する。
  • [表示]-[画面表示]-[メッシュコード、DM図葉コード領域](コマンド:ZoomCode)を「メッシュコード、DM図葉コード等領域」として、新たに、場所情報コード、UTMポイント、(Webメルカトル)タイル番号 (ズームレベル)-(X)-(Y)に対応した。

2018/02/15 [7.713]
  • ADO接続文に関して、%variableName%の環境変数文字列の部分を、その環境変数の現在の値に置き換えで実行されるようにした。
  • [ファイル]-[システム環境]-[システム環境設定]-[ドッキングバー]パネルで、「フローティング・移動の禁止」を試験的に新設。
    メニューバーとツールバーのチェックボックスを追加した。
  • [ファイル]-[システム環境]-[システム環境設定]-[操作3]パネルで、
    • 「辞書DBの検索を当該プロジェクト内のDBに限定して高速化する」チェックボックスを新設。
      レイヤーの内部属性にリンクするものや他のプロジェクトのDBにリンクするケースでは使用できない。
      大量に辞書DBを使用する場合などプロジェクトの起動時などの高速化に有効。
    • 「リンク切れ外部ファイル「保全」モード」を新設。
      従来iniファイル制御していたものを明示的に利用できるようにした。
      ≪参考≫
      プロジェクト起動時に外部ファイルが(ファイルが存在しない等で)読み込まれなかったケースに関して、従来は、その旨メッセージを出して、読み込まれたものだけでのプロジェクトを生成していた。
      この場合、プロジェクトを保存すると、読み込まれなかった外部ファイルに関する情報はプロジェクトから抹消される。
      Pcm.iniファイルで、
      [PcmApp]
      BrokenLinkMode=1

      を設定する事で、読み込まれなかった外部ファイルのレイヤー、データベース、描画パラメーターに関して外部ファイルの情報のみを保持した空のレイヤー、データベース、描画パラメーターを生成してプロジェクトに登録し、このプロジェクトが保存される際、外部ファイルの情報が保全されるようにした。
      なお、この空のオブジェクトはプロジェクトワークスペースでは【BROKEN LINK】でマークされたパス名が表記される。
  • NetViewの[ネットワークデータファイルを開く]ダイアログボックスに関して、iniファイルで
    [NetViewDlg]
    DisableFlags=7

    を追加する事で、URLのエディットボックス、<更新>ボタン、<設定>ボタンをディスエーブルにできるようにした。
  • プロジェクトワークスペースの表示項目に関して、当該プロジェクトのキーリストで
    • NoPwsLayer…レイヤー
    • NoPwsDispMode…表示モード
    • NoPwsRender…描画パラメーター
    • NoPwsEnv…環境
    • NoPwsDb…データベース
    • NoPwsWai…広域イメージ
    • NoPwsWaline…広域ベクター
    • NoPwsPicture…背景ピクチャー
    • NoPwsHMesh …標高メッシュ・TIN
    • NoPwsBkMgr…背景プロジェクト
    • NoPwsKeyList…キーリスト
    • NoPwsMemo…メモ
    • NoPwsWms…WMS/WMTS
    • NoPwsCLP…ポイントクラウド
    それぞれを1にセットする事で、項目を非表示となるようにした。
  • タスクバーの設定ファイルpcm.ptskを起動時にロードする際、pcm.ptsk.add1〜pcm.ptsk.add9までのファイルがあれば、それを読み込んでページ単位に追加されるようにした。
  • [ファイル]-[システムツール]-[イメージ変換]-[イメージの統合・再構成]で、開かれているプロジェクトの背景ピクチャーも指定して統合できるようにした。
  • [ツール]-[標高メッシュ効果・解析]-[フィルター・地形解析]でのフィルター機能に
    • 3X3 ガウシアンフィルター
    • 5X5 ガウシアンフィルター
    • 3X3 LOG(Laplacian of Gaussian)フィルター
    • 5X5 LOG(Laplacian of Gaussian)フィルター
    • 平均曲率
    を追加した。

2017/12/25 [7.712]
  • [属性]-[属性照会]-[ポリゴン属性照会]において、(見かけ上)構造化ポリゴンレイヤーであっても、同階層の他のポリゴンも検索し、重なっている場合、複数列挙できるするようにした(シェープファイルをインポートした場合などに対応)。
    pcm.iniファイルで、
    [PcmAttrInq]
    PolMultiInq=0

    この機能を抑制する事ができる。
  • [ファイル]-[エクスポート]-[ベクトル(GeoJSON)タイル]に関して、複数レイヤーが指定された場合、出力レイヤー順を後書き優先になるようレイヤーの順番、重み、前景・背景を加味して出力するようにした。
  • 16bit階調のTIFF画像の読み込みに関して、従来はデフォルトでは最大値で規格化して読み込んでいたが、最大・最小値で規格化して読み込むようにした。
  • [属性]-[全データ検索]の[全データ検索]ダイアログボックスをモードレスとして、他の機能と併用できるようにした。
  • ≪ブックマークの自動保存、読み込み機能≫
    ブックマークは通常プロジェクトに保存され、読み出されるが、[表示]-[ブックマーク]-[ブックマークの整理]で「ブックマークの自動保存、読み込み」チェックボックスを追加。
    これがONの場合は(そのプロジェクトだけでなく、すべてのプロジェクトに関して)、プロジェクト終了時(たとえプロジェクト自体が保存されなくても)プロジェクトファイル名+"*.pcmbms"とした外部ファイルに保存される。
    次のプロジェクト読み込み時に取り込まれてプロジェクト内のブックマークを上書きする(サイズの大きいプロジェクトの利用時などに有効)。
  • [ファイル]-[インポート]-[法務省地図XMLフォーマットデータ](コマンド:ImportMinjiTizu2)に関して、専用ダイアログを出して設定、取り込みができるようにした(従来のコマンド:ImportMinjiTizuも使用可能、アプリケーションメニューのカスタマイズをしている場合は、このメニューに関しては改めて設定する必要あり)。
  • [設定]-[タイル形式画像背景表示設定](コマンド:RasterTileUrl)を追加。
    地理院タイルと同様の形式で格納された画像ファイル群をズームレベルに応じて背景表示する。
  • [選択]-[個別選択]-[アーク路線選択](コマンド:SelArcNet)を追加。
    始点、終点ノードを指定して、その間を最短経路で結ぶアークを選択状態にする。
  • [作図]-[補間点操作]に関連して、
    • コマンド:BoOpMove…補間点(ノード)移動
    • コマンド:BoOpAdd…補間点追加
    • コマンド:BoOpDel…補間点削除
    を追加。
    それぞれ独立して、マウス左ボタンでの操作ができる。

2017/11/01 [7.711]
  • [ツール]-[UAVコース]-[UAV撮影コース設計(カメラ撮影)](コマンド:UAVCourseSetup3)を追加。
    ※UAV(カメラ撮影)に特化した飛行計画設計ツール
    • 比高一定でのサイドラップ、オーバーラップを算出
    • 中抜けポリゴンの回避ルート生成機能オプションあり
  • 高DPI対応に関して、[ファイル]-[システム環境]-[システム環境設定]-[ルックアンドフィール]パネルで、
    • なし(仮想デスクトップでのスケーリング)…※従来通り
    • あり(PC-MAPPINGによるスケーリング)
    を選択できるようにした。
    後者を選択した場合、Windows仮想デスクトップでのスケーリングはOFFとなり、ディスプレイ設定の拡大率に応じた表示処理が行われる。
    ツールバー、クイックバーのボタンサイズ、フォントサイズに関して、ピクセル値、ポイント数を96DPIにおける論理ピクセル、論理ポイントとして解u釈して、高DPIの環境では、拡大率に応じてサイズを換算して表示するようにした。
    [ファイル]-[システム環境]-[システム環境設定]-[表示と印刷]パネルで、「ウィンドウズ規定のDPI値に固定する」がONの場合は、起動マシンのディスプレイ設定のDPI値を使用する(マシン環境が変わっても同様の表示・表現となる)。
  • [ファイル]-[エクスポート]-[Webメルカトルタイル画像]で、透過色を指定できるようにした。
  • [編集]-[編集作図]-[同一属性要素間アーク作図]で、「「めがね線」オプション(円弧で作図する)」チェックボックスを追加。
  • [選択]-[選択ベクターのみ表示(非選択レイヤー非表示)](コマンド:HideUnSelA)を追加。
    従来の「選択ベクターのみ表示」に対して、選択要素がないレイヤー要素も非表示となる。
  • [属性]-[固有属性転記]でアークに関して、「ユニオン起点側からの距離」を追加。
  • [ファイル]-[システムツール]-[画像処理]-[イメージ比較・差分抽出](コマンド:ImageCompare)を追加。
    指定の2つの画像を比較し、異なるピクセルの箇所を画像にして表示する。
    フォルダーを指定して同一ファイル名の画像を比較する事もでき、PNG,TIFF,BMP,NAIファイルが対象。
  • Pcm.iniで、
    [PCMDateTime]
    GengoMode=1

    で、日付時刻型の元号表示に関して、Windows認識の元号が表記されるようにした(将来的に、これがデフォルトになる予定)。
  • [編集]-[レイヤー]-[図郭をデータ領域に変更]で、「レイヤ毎に、そのレイヤーのデータ存在領域に調整する」モードを追加。
  • [編集]-[交点・ダブリアーク]-[交点ノード生成、ダブリアーク削除]で、「(ダブりアーク削除時)選択されているアークを優先して保持する」オプションを追加。

2017/09/07 [7.710]
  • [カラー変換]-[24ビットカラー]で、CMYK画像からRGBへの変換で、従来は単純論理式での変換であったものをWindowsCodecカラープロファイルを使っての変換に対応した。
  • [属性フィールドの設定]ダイアログボックスで、データベースリンクの「データベース」「フィールド」に関して、検索機能を追加(登録データベースやフィールド数が膨大な場合に適応)。
  • [プロジェクトエキスパート]-[背景ピクチャー]パネルに取り込んだ複数データを、まとめてフォルダー指定で保存する際、元の背景ピクチャーが外部ファイルの場合は、元のファイル名、元の拡張子を使って指定フォルダーに保存されるようにした。
  • [ファイル]-[エクスポート]-[GeoJSONデータへのエクスポート]で、「エクスポートスキーマを使用する」オプションを追加。
  • [ファイル]-[エクスポート]-[ベクトル(GeoJSON)タイル]で、「エクスポートスキーマを使用する」オプションを追加。
  • [ファイル]-[システム環境]-[システム環境設定]-[操作2]パネルで、「ワールドファイル読み込み時での座標系」の設定を追加。
    ワールドファイル自体には座標系の情報がないため、ここでの設定(※設定はEPSGコード)があればそれに従ってセットされる。
    現時点で対応しているEPSGコードは、
    • 2443〜2461:JGD2000 直角座標1系〜19系
    • 6669〜6687:JGD2011 直角座標1系〜19系
    • 4612:JGD2000 経緯度座標
    • 6668:JGD2011 経緯度座標
    • 3857:Webメルカトル
    など。
  • [作図]-[アーク作図・編集]-[補間点指定円弧作図](コマンド:ArcArc)を追加。
    補間点をIP点として、曲率半径を指定、もしくはBP(EP)点を指定して円弧を作図する。
  • [作図]-[アーク作図・編集]-[アーク追加 ノード間](コマンド:ArcAddNode)を追加。
    ノード間に限定して、アーク(補間点なし)を作図する。
  • [ツール]-[UAVコース]-[UAV撮影コース設計(レーザースキャナー)](コマンド:UAVCourseSetup2)を追加。
    ※レーザースキャナー搭載のUAVに特化した飛行計画設計ツール
  • [属性]-[属性照会]-[マルチレイヤー・マルチ要素属性照会](コマンド:MElmInq)を追加。
    指示点を含むポリゴンと検索範囲内のポイント、ノード、アークの属性リストを表示する。
  • メニューにないコマンド:WriteProfileを追加。
    pcm.iniファイルに指定のデータを書き込む。
    【書式】WriteProfile△(セクション名)△(エントリー名)△(値)

2017/06/29 [7.709]
  • イメージ:[図法変換]-[画像の図法変換]に関して、ダイアログボックスの設定で外部ファイル(TIFF・NAI)を複数指定して同時に変換できるようにした。
  • [作図]-[アーク作図・編集]-[円・円弧]での「3点指定の円弧作図(円周上の3点を指定)」において、既存の端点ノードにShiftキーでのスナップ、あるいは中ボタン(Ctrl+左ボタン)でのスナップした場合、そのアークを接線とする円弧を次の1点を指定することで作図する。
    中ボタンの場合は既存のアークと結合ノードを作って接続する。
  • [作図]-[アーク作図・編集]-[アーク追加(直線+円弧)](コマンド:ArcAddLineArc)を追加。
    直線と円弧作図をスペースキーによって切り替えで連続作図を実行する。
    また、直線から円弧への移行時はその直線を接線とする円弧を作図し、円弧から直線移行時はALTキーを併用することで円弧終端の接線方向に直線を作図する。
  • [ツール]-[UAVコース]-[UAV飛行計画コース CSV/AWN形式エクスポート](コマンド:ExportUAVCsv)を新設。
    UAVコース設計後、手編集したコースを(前景レイヤー)CSV/AWM形式に出力する。
  • [ツール]-[UAVコース]-[UAV飛行計画コース 反転](コマンド:UAVCourseInv)を新設。
    UAVコース設計後、飛行計画コースを反転させる。
  • [UAVコース設計]・[UAV撮影コース設計(レーザー点群)]ダイアログボックスで、
    • 連結後コースあたりの最大長をダイアログを出して、平均速度と滞空時間から算出できるようにした。
    • 撮影コースの方向に関して、現在値より90度単位で回転させるボタンを追加。
  • [編集]-[TINと標高メッシュ]での地理院地図標高タイルデータの取り込みに関して、DEM5(ZOOM=15)に対応した。
    DEM5Aを優先し、なければDEM5Bを取り込む。
  • 「ズームバー」に関して、マウス右ボタンメニューで、
    • 拡大率 X1 X2 X5 X10の指定
    • 十字マークのOn/Off
    • 距離ティックのOn/Off
    を選択できるようにした。
  • [ツール]-[断面図・縦断図]-[断面図作成プロパティ]で、ポイントクラウド上での断面図生成に対応した。
  • [印刷]-[整飾プロジェクトプレビュー]-[整飾プロジェクト印刷プレビュー設定]で、複数(最大4つまで)のプロジェクト(ベクタードキュメント)を整飾プロジェクトの指定のレイヤー枠に割り当てて表示、印刷できるようにした。
    また、縮尺を連動、比率指定連動、固定値を指定できるようにした。

2017/04/20 [7.708]
  • 表示モードからその内部に格納されている「レイヤー表示モード」を抹消する機能を追加。
    [プロジェクトエキスパート]-[表示モード]で、<現在のレイヤー表示モードを格納>ボタンを<レイヤー表示モードメニュー>ボタンに変更。
    このボタン押下で、
    • 選択表示モードに、現在のレイヤー表示モードを格納する
    • 選択表示モードからすべてのレイヤー表示モードを抹消する
    の2つのメニューを選択できる。
  • [印刷]-[矩形ポリゴン指定による連続印刷]に関して、従来は矩形ポリゴンのサイズ等から回転方向などを自動調整していたが、これに加えて、
    • 右周りポリゴンの第1点目を紙の左下にしての回転を想定する
    • 右周りポリゴンの第2点目を紙の左下にしての回転を想定する
    • 右周りポリゴンの第3点目を紙の左下にしての回転を想定する
    • 右周りポリゴンの第4点目を紙の左下にしての回転を想定する
    オプションを追加した。
  • [編集]-[レイヤー]-[ポリゴン3DView設定](コマンド:Pol3DView)を追加した。
  • [編集]-[レイヤー]-[注記3DView設定](コマンド:Text3DView)を追加した。
  • [印刷]-[整飾プロジェクトプレビュー]-[整飾プロジェクト印刷プレビュー設定]で、複数(最大3つまで)のプロジェクト(ベクタードキュメント)を整飾プロジェクトの指定のレイヤー枠に割り当てて表示、印刷できるようにした。

2017/03/14 [7.706]
  • 「印刷」のビットマップ出力、および、ウィンドウズ印刷の「仮想ビットマッププリンター」に、32ビットカラーでの背景透過もードを追加。
    この場合、[環境-1]のシステムパレットの背景塗りつぶし(紙色)ブラシのカラーを透過とする32ビット画像を生成する。
  • [編集]-[編集作図]-[アークをポイント位置へ伸縮]で、しきい値内のアークを全て伸縮するオプションを追加した。
  • [表示]-[ブックマーク]-[ブックマークの追加]にコマンドパラメーターを追加。
  • 整飾プロジェクトにおけるプレースホルダー文字列として、
    • %POS1X2D%
    • %POS1Y2D%
    経緯度の表現方法を「141°10′15.00″」になるものを追加した。
  • [プロジェクトエキスパート]-[背景プロジェクト]パネルに、「タイル画像取得、背景描画」を追加。
    地理院タイルと同形式の画像セットのURLやフォルダーを設定する事で、地理院地図と同様に背景表示可能。
  • [編集]-[編集作図]-[ポイントからアーク補間点移動・生成](コマンド:PntToVertex)を追加。
    指定レイヤーのポイント位置のしきい値ない補間点がなければ追加する。
    補間点位置はアーク上、もしくは、ポイント位置を指定できる。
  • [編集]-[レイヤー]-[矩形ポリゴンによる分割]で、ポリゴンの境界部分を閉じる、閉じないのオプションを追加。
  • [編集]-[Z値]-[TIN、標高メッシュからのZ値付与]で、TIN、標高メッシュと異なる座標系のレイヤーに対応した。
  • [選択]-[選択状態転記(レイヤー間)]で、異なる座標系のレイヤー間の転記に対応した。

2016/12/26 [7.705]
  • [編集]-[図法変換]-[経緯度座標からランベルト正角円錐図法へ変換]で、原点を明示的に指定できるようにし、その位置が仕上り紙面上の中央に配置されるようにした。
    また、「新規にプロジェクトを生成する」オプションを追加し、この場合、新しいレイヤーとして変換後のレイヤーが生成され、新しいプロジェクトに配置されるようにした。
  • [ツール]-[表示領域検索]-[表示中心付近をGoogle Mapsで閲覧]に関して、コマンド:GMView△-thで航空写真重ね合わせモードで表示されるようにした。
    表示領域検索
  • ベクター:[ツール]-[標高メッシュ効果・解析]-[傾斜量図](コマンド:BvView51)
    標高メッシュ:[効果]-[傾斜量図](コマンド:BvView51)
    を追加。
    いずれも、従来の"傾斜区分図(段彩図)"と類似するが、陰影処理、等高線付加機能はなく、計算方式として、Prewitt法とSobel法を明示して選択できるようにした。
    ※ただし、この機能を実行するには、あらかじめ構成標高メッシュを結合しておく事が必要。
  • [プロジェクトエキスパート]-[WMS/WMTS]パネルで、それぞれの設定で、アルファブレンドに加えて、乗算ブレンドのモードを追加した。
  • [選択]-[選択ベクター(前景レイヤー)のみ表示](コマンド:HideUnSelF)を追加。
    前景レイヤーのみ「選択ベクターのみ表示」となる。
  • [属性フィールドの設定]ダイアログボックスで、「入力禁止(表示のみ)」チェックボックスを追加。
    ONの場合、このフィールドのデータを属性照会や属性ウィンドウ上で直接キーボードからの入力を抑制する。
  • [ツール]-[表示領域検索]-[表示中心付近をGoogle Mapsで閲覧]に関して、コマンド:GmView△-BarCodeで、現在の位置を中心にGoogleMapsで見るためのURLを2次元バーコードで表記したものをブラウザで表示する。
    表示領域検索
  • メニューにないコマンド:ImportEVMapを追加。
    環境省1/25,000植生図GISデータを、ZIPファイルを直接解凍してインポートする。
    また、フィールド名も日本語に変更し、整数型になるフィールドは整数型にセットする。
    1/2.5万植生図GISデータ [環境省生物多様性センター]

2016/09/07 [7.704]
  • [ツール]-[想定整形地の生成]-[想定整形地の生成(一括処理)]で、新規に生成される想定整形地レイヤーのポリゴンタイプを必ず1アーク1ポリゴンになるように調整した。
    想定整形地の生成 [一括処理]
  • HTML記法で、従来、
    font size=NNNで、NNN=1,2,3,4,5,6,7が8、10、12、14、18、24、36論理ポイントに対応する

    font size=NNNxxで、
    • NNN = 数値
    • xx = 単位(px:ピクセル/in:インチ/cm:センチ/mm:ミリ/pt:ポイント/%も指定可)
    などが指定できるようにした。
    また、単位なしの場合、NNN=1,2,3,4,5,6,7,8,9,10が8、10、12、14、18、24、36、48、64、96論理ポイントに対応する。
    【属性表示】属性のHTML記法
  • [印刷]-[表示領域を現在の印刷枠に移動](コマンド:PrintViewArea)を追加。
  • [ツール]-[空間統計解析]-[ポリゴンランダムフィル(4色定理)](コマンド:PolFCFill)を追加。
    アークを共有する隣接ポリゴンが同色にならないように振り分ける(※構造化ポリゴンである事が必須)。
    数学理論上4色あれば振り分け可能だが、実装上最低でも5〜6色程度は使用される。
    また、コマンド:PolFCFill△-MaxCol△nnで使用する色数(=n)を指定する事も可能。
  • ポリゴンの属性表示に関して、レイヤーのキーリストに@PolAttrCPos = 2をセットする事で、そのポリゴンに中心点があって、表示範囲内にその中心点があれば中心点位置に、なければ表示されているポリゴン内の適当な位置に表示されるようにした。
    また、1つのポリゴンが複数に分割されて表示されるケースでは、それらの全ての(分割された)ポリゴンに属性が表示されるようにもした。
  • [作図]-[スナップ設定]で、「スナップ情報をツールチップ表示する」チェックを追加。
    ONの場合、スナップしたレイヤー名やどの要素にスナップしたかの情報を表示する。
  • [ツール]-[空間統計解析]-[ポリゴン包含ポイント集計]で、
    • 包含ポイントの指定属性値ごとにポイント数を集計し、ポリゴン属性にセットする
    • 包含するポリゴンの指定属性値ごとにポイント属性にセットする
    を追加。
  • [印刷]-[矩形ポリゴン指定による連続印刷]で、「ユニオン(あれば)単位で」のチェックを追加。
    これがONの場合、ポリゴンのユニオン単位に出力される。
    図葉メッシュ単位に印刷する(矩形印刷)
  • データベース:[編集]-[座標データ]-[座標データのショートベクター変換]で、「(ショートベクターではなく)左下、右上の矩形ポリゴンを生成する」オプションを追加。
    始点、終点を左下、右上と読み替えて矩形のポリゴンを生成する。
  • [ツール]-[画像ファイル]-[矩形ポリゴンから画像図郭座標付与](コマンド:TouchGeoTiff)を追加。
    ポリゴンの内部属性に画像ファイルへのパス設定があれば、ポリゴンの矩形領域をその画像の図郭情報として、GeoTiffファイルやワールドファイルとして保存する。

2016/06/30 [7.703]
  • [ツール]-[空間統計解析]-[ポリゴンオーバーレイによる面積クロス集計]で、「ラスターピクセル計数方式で処理する」オプションを追加。
    解像度を指定して内部的に画像を生成し、その合成ピクセルをカウントして面積クロス集計を実行する。
    指定される解像度までに限定されるが、ポリゴンオーバーレイによる構造的エラーによる集計エラーを回避でき、また、一般に高速な処理が期待できる。
  • [プロジェクトエキスパート]-[署名と権限]パネルに、「外部ファイルを相対パスで保存」チェックを追加。
    プロジェクト保存時に、外部ファイルのパス名をプロジェクトファイルからの相対パスにして管理する。
    これらは読み込み時に絶対パスに変換されて、取り込まれ再度プロジェクト保存時まで絶対パスで管理される。
  • [印刷]-[矩形ポリゴン指定による連続印刷]で、 ポリゴンのフィールドに縮尺分母を入力しておき、その縮尺に合わせて印刷できる機能を追加。
    • 「(矩形でなく)任意のポリゴン領域を印刷する」チェックボックス=ON
    • 「印刷設定での縮尺で印刷する」チェックボックス=OFF
    • 「ポリゴン属性で縮尺を個別指定」ドロップダウンリストから縮尺分母を入力したフィールドを選択
    して実行する。
    その際、ポリゴン内部属性に「@Scale範囲Check」フィールドがあれば、印刷領域とポリゴン領域の比を計算し、100分率で格納するようにした。
    図葉メッシュ単位に印刷する(矩形印刷)
  • [編集]-[編集作図]-[アーク平滑化]で、「指定より短いセグメントの補間点を削除」する際、「これ以下の夾角では対象外」のオプションを追加。
    これを0にすると、夾角判定をしない。
  • データベース:[編集]-[演算、集計、分析]-[クロス集計](コマンド:DbCalcCross)を追加。
    ロウ側になるフィールド、カラム側になるフィールド、演算するフィールド、集計方法などを指定して集計した表(データベース)を生成する。
  • [設定]-[地理院タイル等表示設定]で、「拡大・縮小時の視覚効果」チェックを追加した。
    ※地理院地図以外に広域イメージ等で画像を重ね合わせている場合や地理院地図自体を多重に重ね合わせている場合は使用できない(画像が乱れる)事がある。
    【地理院地図】地理院タイル(旧電子国土Webシステム背景画像)等表示機能
  • [ファイル]-[システムツール]-[イメージ変換]-[イメージの統合・再構成]で、変則図郭の画像にも対応した。

2016/04/01 [7.702]
  • イメージの重ね合わせ表示に関して、従来のアルファブレンドに追加して「乗算ブレンド」を追加。
    「レイヤーの背景イメージ」・「背景ピクチャー(画像)」・「広域イメージ」・「標高メッシュの段彩陰影図」に関しても対応した。
  • データベース:[編集]-[文字列変換]で、変換方法に
    • 絶対パスを相対パスに
    • 相対パスを絶対パスに
    を追加。
    そのDBのパス、あるいは、そのDBを内部属性に持つレイヤーのパス、あるいは、そのDBを含むプロジェクトのパスが参照される。
  • 広域イメージ、背景ピクチャー、レイヤー背景イメージで、透過色に対し、その近傍色も透過させる機能を追加。
    各設定で、その「近傍度合」を1〜10(大きい方がより離れた色でも透過する)で指定する。
  • [ファイル]-[システムツール]-[イメージ変換]-[統合広域イメージの生成]で、白透過色に対し、その近傍色も透過させる機能を追加。
    [統合広域イメージの作成]ダイアログボックスで、「透過白色近傍レベル」を1〜10(大きい方がより離れた色でも透過する)で指定する。
    統合広域イメージ機構
  • [設定]-[地理院タイル等表示設定]からの詳細設定で、1つのズームレベルに複数の種別タイルを指定できるようにした。
    また、地理院地図の表示に関して、ブレンド(乗算ブレンド、アルファブレンド)を指定できるようにした。
    地理院タイル(旧電子国土Webシステム背景画像)等表示機能
  • PVP(プレゼンテーションビューアーパック)の生成に関して、「プロジェクトデータを別ファイル(拡張子*.pvp)に分離して出力する」オプションを追加した。
    これにより、論理的には2GBを超えるプロジェクトデータに関しても処理可能となる(実用上は64ビット版が必要)。
    プレゼンテーションビューアパック
  • [プロジェクトエキスパート]-[背景プロジェクト]パネルからの背景プロジェクトの設定で、「指定オーダーで表示する」オプションを追加。
    表示モードの「描画順位カスタマイズ」で追加された「背景プロジェクト(オーダー指定)」の順位でまとめて描画されるようにした。

2016/04/01 [7.701]
  • 【PC-MAPPING Ver.7.7がリリースされました】
    システム構成に一部変更があり、そのため、PC-MAPPINGからの「最新版の検索」メニューでは、現行PC-MAPPING Ver.7.6xxからVer.7.7xxへの(自動)更新はできません。
    お手数ですが、最初の1回は最新版ダウンロードページからアップグレードをお願いいたします。
    最新版ダウンロード PC-MAPPING Ver.7