サポート > 機能更新履歴(機能追加・障害報告) > Ver.8.001〜Ver.8.009
 機能更新履歴(機能追加・障害報告)_ Ver.8.001〜Ver.8.009

Ver.8.020〜
Ver.8.010〜Ver.8.019
Ver.8.001〜Ver.8.009
Ver.7はこちら
2020/06/22 [8.009]
  • [ツール]-[UAVコース設計]-[サイドラップ等を再計算](コマンド:UAVCourseSL)を追加。
    すでに計画、作図され、あるいは修正されたコースレイヤーに対して、サイドラップ等を再計算する。
  • [ツール]-[UAVコース設計]-[レーザー点群密度推定](コマンド:UAVCourseDotDensity)を追加。
    [UAV撮影コース設計(レーザー)]で設計したコースや作図したコースレイヤーに対して、計測データの点群密度を推定・検証するため、レーザー照射位置にポイントデータを生成し、照射角度、距離などを算出する。
  • PC-MAPPING HTオプション製品「空中写真撮影管理キット」の機能に、コマンド:APhotoCourseOrthoを追加。
    POS-EO形式の標定ファイルを読み込んでその情報より、該当する空中写真画像ファイルをオルソ変換する。
    【What's new?】「航空写真精度管理表」オプションキット追加
  • [ワークスペース]-[コマンドヘルプ]パネルを新設。
    • コマンド検索(コマンド:??):従来のコマンド検索バーからのダイアログを直接起動する。
    • 直前のコマンド(コマンド:LastCommandMgr):直近まで実行したコマンドをリストし、必要に応じて再実行する。
    追加。
  • [システム]-[統合標高メッシュ]-[生成]を追加。
    従来、標高メッシュの組み立てダイアログにあった機能を整理、移植した。
    統合標高メッシュ生成後は標高プロジェクトとして表示される。
  • メニューにないコマンド:InputBoxを追加。
    文字列を入力するダイアログを開いて、ユーザーの入力を即して、その結果を指定する次のコマンドへと引き渡す(HT/SP/NV/PVPEXで使用可)。
    【書式】InputBox△(オプション)
    【引数(オプション)】
    • -Title…ダイアログのタイトル
    • -Message…ダイアログ上のプロンプト
    • -InitKey…入力文字列の初期値(あれば)
    • -はいいいえ…【はい】【いいえ】の2つのボタンを表示
    • -はいいいえキャンセル…【はい】【いいえ】【キャンセル】の3つのボタンを表示
    • -OKキャンセル…【OK】【キャンセル】の2つのボタンを表示
    • -OK…【OK】のみのボタンを表示
    • -FileOpen…[ファイルを開く]のダイアログ用ボタンを追加
    • -FileSave…[ファイルを保存]のダイアログ用ボタンを追加
    • -Filter…ファイル拡張子を指定する文字列
    • -Folder…[フォルダーを選択]のダイアログ用ボタンを追加
    • -NewFolder…[フォルダーを選択(新規フォルダーメニューあり)]のダイアログ用ボタンを追加
    • -NextCmd…【はい】【OK】ボタンが押された場合、次に実行するコマンド
    • -NextCmdNo…【いいえ】ボタンが押された場合、次に実行するコマンド
    • -NextCmdCancel…【キャンセル】ボタンが押された場合、次に実行するコマンド
    • -NextCmdAbort…【閉じる(X)】ボタンやESCキーで終了した場合に実行するコマンド
      (*1)-NextCmdは必須、その他はオプション
      (*2)任意の文字列を設定でき、その中で、@@KEY@@の文字列部分が入力文字列に置き換えられて実行される。
  • [スタート]-[システム環境設定]に「データベース」タブを追加。
    「データベースウィンドウ背景配色」を明示的に指定できるようにした(従来はpcm.ini設定)。
    【pcm.ini】データベースに関する設定

2020/05/29 [8.008]
  • リボンカスタマイズにおいて、OKボタンで、
    • 更新して、閉じる
    • 更新して、再起動
    • カスタマイズ保留を解除して更新、再起動(※このメニューはカスタマイズ時に「カスタマイズ保留」チェックボックスがOnの場合に表示される)
    を選択できるようにした。
  • 解析フィルター機能
    • 標高メッシュ:[標高]-[効果]-[フィルター・地形解析]
    • ベクター:[ツール]-[標高メッシュ]-[フィルター・地形解析]
    に、「結果のデータをプロジェクトに登録」のオプションを追加。
    これがONの場合は、独立した標高メッシュドキュメントを作らずに、現在のプロジェクトに新しくできたメッシュデータを追加する。
    • 「ピークポイント抽出」
    を追加。
    指定の周囲NxNメッシュより標高値が大きい位置にポイントを生成する(他の機能と異なり、ポイントのレイヤーを生成する)
    • 「NxN 統計フィルター(平均値)」
    • 「NxN 統計フィルター(最大値)」
    • 「NxN 統計フィルター(最小値)」
    • 「NxN 統計フィルター(中央値)」
    を追加。
    周囲NxNメッシュの値から統計値を求める。
  • ユーザーメニューの「チェック」「イネーブル・ディスエーブル」の制御コマンド:UserMenuCtrlを追加。
    【書式】UserMenuCtrl△(ユーザーメニュー名)△(機能オプション)
    【引数(機能オプション)】
    • CheckOn…チェックOn状態(リボン上では「選択押下」状態)にする
    • CheckOff…チェックOff状態にする
    • CheckToggle…On→Off・Off→Onに移行する
    • Enable…通常状態(使用可能状態)にする
    • Disable…ディスエーブル状態(使用不能状態)にする
    • Clear…制御情報をクリアーして初期状態に戻す
  • [ワークスペース]-[カスタマイズ]-[ユーザーメニューの定義]に、「チェックボックス」「ラジオボタン」のオプションを追加。
    • チェックボックス、ラジオボタンの初期値は上記のコマンド:UserMenuCtrlを使って設定する必要がある。
    • ラジオボタンに関しては、ユーザーメニュー定義のリスト上で連続するものを1つのグループとして扱う。
    • これらに関して「初期状態をONにする」のチェックも設定。
    ユーザーメニューの定義
  • [プロジェクト]-[プロジェクト2重化]-[領域指定でプロジェクトの切り出し](コマンド:PrjCut2)について、コマンドパラメーターの指定方法を、para1からの順番でなく、固定文字列による順不同の記述形式を採用した。
    【引数(オプション)】
    • -Mode△n…領域指定方法
    • -PolLayerName△"ポリゴンの存在するレイヤー名"
    • -ModeSub△n…領域指定
    • -Frame…図郭線を生成する
    • -MaskLayer…切断領域のマスクレイヤーを生成
    • -PolShpMode…ポリゴンは「包含関係のみ構造化」レイヤーに変換して切り出す
    • -PolFrame…変則図郭切断を行う
    • -PolMargin…指定ポリゴンにマージンを指定
    • -PolMarginWidth△mm…指定するマージン幅(m)
    • -Border…境界線上は含まれるとみなす
    • -Pos△X1△Y1△X2△Y2…領域指定の座標(X,Yは数学的座標)
    • -NoDlg…ダイアログを出さずに実行する(座標指定ない場合は、座標指定のマウストラックモードになる)
    領域指定でプロジェクトの切出し
  • [データベース]-[編集]-[座標データ]-[フィールドデータのベクター変換](コマンド:DbTextToVec3)を追加。
    指定にフィールドにある文字列を、X Y X Y…の座標列としてベクターデータに変換する。
  • [インポート]-[CAD]-[CADデータ交換標準フォーマット(SXF)]において、「ルールチェックの処理をスキップする」オプションを追加。
    SXFファイルのインポート

2020/04/27 [8.007]
  • [エクスポート]-[汎用]-[GoogleEarth(Googleマップ)KMLファイル]に関して、
    レイヤーのキーリスト
    • foldername=フォルダー名…レイヤーのフォルダー名
    プロジェクトのキーリスト
    • foldernameT=フォルダー名…トップレベルのフォルダー名
    • foldername=フォルダー名…その下のフォルダー名
    • foldername=@NoFolder…フォルダー自体を無しにする
    • FolderMode=1…プロジェクトのフォルダー構成を再現してエクスポートする
    を指定できるようにした。
    GoogleEarth KMLファイルへのエクスポート
  • KMLエクスポートに関して、「広域イメージをエクスポート」オプションを追加した。
  • ZIP64対応モジュール(PcmZlib.dll)公開。
    これを64ビット版pcm.exeのフォルダーに置くことで、起動時のメッセージウィンドウに
    ---
    PcmZlib.dll (Zip64) ver 7.7.0.0.
    ---
    が出現し、pcmzz navzz ndvzzの保存、読み込み時や他のZIPファイルの解凍時において、64bit仕様ZIP/ZLIBとしての4GB超のZIPファイルの処理に対応する。
    4GB超でなければ、32ビット版との互換性のある形式となる。
  • [編集]-[編集]-[選択編集]-[レイヤー間移動・コピー]のポリゴンの[移動]について、従来ポリゴンに関しては、保全されるようにしてしていたが、移動時には破棄されるように変更した。
    ※ただし、対象がポリゴンのみの場合。対象がアークの場合は、元のレイヤーに残る。
  • データベース処理の
    • [データベース]-[編集]-[編集]-[フィールド結合]
    • [データベース]-[編集]-[編集]-[フィールド照合・転記]
    • [データベース]-[編集]-[編集]-[レコード結合]
    • [データベース]-[レコード]-[レコード編集]-[他のDBリストからの検索]
    において、リストされるデータベースに関して、そのキーリストに@NoMenuList=1の記述があれば非表示とされるようにした。
  • 拡張PVPで、相手方プロジェクトを同一フォルダーに置くことで、表示領域連動プロジェクトが復元されるようにした。
  • [拡張]-[スナップショット]-[ファイル]-[スナップショットファイル]に、「プライマリースクリーンエリア」をコピーするを追加。
    複数モニター環境で、プライマリースクリーンのみをコピーする。
  • [標高メッシュデータの組み立て]ダイアログボックスで、ダイアログウィンドウをサイズ可変とした。
    また、標高データが直角座標系の場合、明示的にその系を変更するボタンを追加した。
    標高メッシュデータの組み立て

2020/03/09 [8.006]
  • 計算フィールドの関数に「YearB」を追加。
    「YearB({フィールド名})」で、日付時刻型フィールドを指定して、その内部表現から年度(Buniness Year)を得る。
  • 起動オプション「-OmpThreads△X」に関して、省略時のデフォルトを「-OmpThreads△0」(即ち、マルチスレッド処理あり)とし、[システム環境設定]-[操作3]パネルで「マルチスレッド処理により高速化を行わない」オプションを追加した。
    起動オプション一覧 [概要]
  • [ツール]-[空間統計解析]-[ポリゴンオーバーレイ]-[ポリゴン・背景イメージヒストグラムオーバーレイ]で、前景以外の背景レイヤーの背景イメージも指定できるようにした。
  • ≪コマンドパラメーター 新・記述形式≫
    「法務省地図XML」のインポート(コマンド:ImportMinjiTizu)について、コマンドパラメーターの指定方法を、para1からの順番でなく、固定文字列による順不同の記述形式を採用した。
    【引数(オプション)】
    • -GyName△(行政名):行政名でジオコーディングした結果位置へ平行移動してセット
    • -No図郭:図郭レイヤーを取得しない
    • -No筆:筆レイヤーを取得しない
    • -No基準点:基準点レイヤーを取得しない
    • -No筆界点:筆界点レイヤーを取得しない
    • -No筆界線:筆界線レイヤーを取得しない
    • -No地区外:地区外を取得しない
    • -No別図:別図を取得しない
    • -NoMerge:レイヤー毎のマージ処理なし
    • -OutDir△(出力フォルダー):レイヤー毎にファイル出力する(デフォルトはNAVファイル)
    • -ExportShp:シェープファイルにして出力(-Outdirと併用する)
    • -NoDlg:ダイアログを開かずに実行する
  • ≪コマンドパラメーター 新・記述形式≫
    データベース:[編集]-[演算・集計]-[クロス集計](コマンド:DbCalcCross)について、コマンドパラメーターの指定方法を、para1からの順番でなく、固定文字列による順不同の記述形式を採用した。
    【引数(オプション)】
    • -Key2△(フィールド名):カラム側フィールド
    • -Field△(フィールド名):処理するフィールド
    • -Func△(0〜8):集計機能
    • -Factor△(フィールド名):ファクターフィールド
    • -Sel:選択レコードのみ
    • -Title△(タイトル):出力データベース名
    • -Prj:プロジェクトに登録
    • -KeyField△(フィールド名):ロウ側フィールド(複数列記可能)
    • -NoDlg:ダイアログを開かずに実行する
  • メニューにないコマンド:Proc△Wai△(レイヤー名)
    • Proc△Wai△(レイヤー名)△TpOn:透過モードON
    • Proc△Wai△(レイヤー名)△TpOff:透過モードOFF
    • Proc△Wai△(レイヤー名)△TpColor△#RRGGBB:透過色指定
    を追加。

2020/02/05 [8.005]
  • [システム]-[GPS]-[GPS]-[GPSログから軌跡ベクター生成](コマンド:VideoPlay2)
    「ビデオファイルとリンクする」で、360度動画にも対応した。
    また、位置表示のシンボル(スプライト)で方向を指定して表記できるようにした(北向きのシンボルを用意しておく)。
  • [システム]-[パノラマ]を追加し、
    • 360度静止画像閲覧(コマンド:PanoramaView)
      :円筒図法の360度静止画像を指定して開き、視野変更、拡大縮小等の閲覧
    • 360度動画再生(コマンド:PanoramaVideoPlay)
      :円筒図法の360度動画を指定して開き、その再生と視野変更、拡大縮小等の閲覧
    を追加した。
  • メニューにないコマンド(プロジェクトドキュメント時)
    • SelMarkToDb:内部属性データベースの選択状態をベクター要素に反映する
    • SelMarkFromDb:ベクター要素の選択状態を内部属性データベースに反映する
    オプション(共通)
    • Arc:アークに対して適応
    • Node:ノードに対して適応
    • Pol:ポリゴンに対して適応
    • Pnt:ポイントに対して適応
    (*)データベース側のMarkToVec/MarkFromVecに対応する。
    ドキュメントを切り替えることなく、ベクタープロジェクト上で処理可能。
  • ≪コマンドパラメーター 新・記述形式≫
    [編集]-[編集]-[Z値]-[TIN、標高メッシュからのZ値付与](コマンド:ZFromTin2)について、コマンドパラメーターの指定方法を、para1からの順番でなく、固定文字列による順不同の記述形式を採用した。
    【引数(オプション)】
    • -Arc:アークを対象
    • -Node:ノードを対象
    • -Pnt:ポイントを対象
    • -Sel:選択要素のみを対象
    • -Mark:付与できなかった要素を選択状態にする
    • -Offset:現在のZ値にオフセット
    • -UseCLP:ポイントクラウドから
    • -CLPMode△M:M=付与モード(0:最低値,1:平均値,2:最頻値,3:最高値)
    • -CLPRange△n:n=検索範囲(m)
    • -NoDlg:ダイアログを開かずに実行

2019/12/25 [8.004]
  • [データベース]-[表示]-[全データ検索](コマンド:RecSearchAll)を追加。
    アクティブなデータベース内で、全てのフィールドにわたってキーを指定して検索する。
    絞り込みによる多重検索も可能。
  • [ワークスペース]-[ツール]-[SVG連結](コマンド:SvgConCat)を追加。
    複数のSVGファイルを連結し、1つのSVGファイルにする。
    これにより、ユーザーメニュー用の画像ファイルを生成することができる。
  • [インポート]-[国土数値情報]に関して、ZIPファイルに同梱されるGML/シェープファイル/GeoJSON中、シェープファイルの取り込みをメインとし、GML(JPGIS2.1)ファイルに関しては[インポート]-[国土数値情報]-[その他]の中に移動した。
    ※今後、新たに追加・更新されるデータに関してはシェープファイルを主とし、これに対するインポートスキーマを内部的に用意して対応する。
  • [スタート]-[システム環境設定]-[操作3]に、「再起動マネージャのサポート」チェックボックスを追加。
    これがONの場合、何らかの事情でアプリケーションがクラッシュした場合、自動的にプログラムを同環境で再起動する。
    【注意点】
    ※編集中のドキュメントが復元される訳ではないので、バックアップファイル等の設定は従来通り別途必要。
    ※システム運用上、PC-MAPPINGが常に起動されていることが期待されている場合には有効。
    ※起動1分程度以内ではこの機能は働かない。

2019/11/22 [8.003]
  • [印刷]-[印刷実行]-[矩形ポリゴン指定による連続印刷]において、「(矩形でなく)任意のポリゴン領域を印刷する」チェックがONの場合、
    ---
    【従来の動作】(ヒント集より)
    メッシュポリゴン以外の、任意の形状のポリゴン領域も、同様に連続印刷する事ができます。
    この場合、矩形ポリゴンのように、印刷領域を必要に応じて回転する事はありません。
    また、メッシュの時とは違い、ポリゴン領域指定の場合、そのレイヤーも描画対象となるので、キーリストで選択状態や領域外を塗りつぶす等の設定が行えます。
    この時、任意のポリゴンが存在するレイヤーのキーリストに
    • MARGIN=0.2…その分のマージンをとって印刷領域を設定する
    • CUTMODE=1…ポリゴン領域を切り出して印刷
    • ALPHA=CCFFFFFF…ポリゴン領域外を指定のARGB値(16進)で塗りつぶす
    • MARKMODE=1…該当ポリゴンを選択状態にする
    • FIXSCALE=1…元の縮尺設定で印刷する(FIXSCALE = 0でポリゴン領域に合わせて調整)
    と設定する事で、出来栄えを整える事ができます。
    ----

    これらの指定を[矩形ポリゴン指定による連続印刷]ダイアログボックスで明示的に設定できるようにした。
    図葉メッシュ単位に印刷する(矩形印刷)
  • [ツール]-[画像ファイル]-[座標付与]-[矩形ポリゴンから画像図郭座標付与]について、「四角形ポリゴンの場合、4点の座標を画像四隅座標として独立に付与する」オプションを追加し、回転の掛かった図郭座標付与に対応した。
  • [編集]-[編集]-[編集作図]-[垂線アーク生成](コマンド:ArvVline)を追加。
    アーク代表、セグメント中点からそのアークに垂直なアークを生成する。
  • [イメージ]-[変換]-[Webメルカトルへ](コマンド:ImToWebMerca)、[Webメルカトルから](コマンド:ImFromWebMerca)を追加。
    それぞれ、経緯度座標の画像をWebメルカトルへ変換、あるいは、Webメルカトル画像を経緯度座標に変換する。
    なお、Webメルカトルの画像データも見かけ上は経緯度座標(四隅を緯度経度で指定)であることを想定している。
  • [ツール]-[空間統計解析]-[空間解析]-[ポイントに背景イメージRGB値を転記](コマンド:PntImageOvr)を追加。
    前景レイヤー各ポイント位置の背景イメージ画素のRGB値を属性として転記する。
  • リボンバーカスタマイズ設定時において、最後にカスタイマイズ保存されてから、追加されたメニュー(コマンド)がある場合は、その旨のメッセージを出し、また、左側オリジナルメニューツリーで該当項目を強調するようにした。
    リボンバーのカスタマイズ
  • ≪コマンドパラメーター 新・記述形式≫
    以下のメニューについて、コマンドパラメーターの指定方法を、para1からの順番でなく、固定文字列による順不同の記述形式を採用した。
    • [選択]-[属性選択]-[アーク属性選択](コマンド:SelAttrArc2)←(旧コマンド:SelAttrArc)
    • [選択]-[属性選択]-[ノード属性選択](コマンド:SelAttrNode2)←(旧コマンド:SelAttrNode)
    • [選択]-[属性選択]-[ポリゴン属性選択](コマンド:SelAttrPol2)←(旧コマンド:SelAttrPol)
    • [選択]-[属性選択]-[ポイント属性選択](コマンド:SelAttrPt2)←(旧コマンド:SelAttrPt)
    • [データベース]-[レコード]-[検索](コマンド:RecSearch2)←(旧コマンド:RecSearch)
    【引数(オプション)】
    • -key△([フィールド番号]または<フィールド名>)△(条件)△(検索する値または文字列)△(and or):検索キーとなるフィールド・条件式(条件番号)を設定する
    • -mode:処理モード
        0 = 全レコード対象に検索し、検索ヒットとしたレコードを追加して選択状態にする
        1 = 全レコード対象に検索し、検索ヒットとしたレコードのみを選択状態にする
        2 = 選択レコードを対象に検索し、検索ヒットとしたレコードのみを選択状態にする
    • -LastKey:前回使用した検索条件をそのまま維持する
    • -ClearMark:検索ヒットしなかった場合、現在の選択状態をクリアーする
    • -SelectDisp:「絞込み表示」チェックボックス
    • -LinkKeySearch:「(データベースリンクの場合)リンクキーで検索する」チェックボックス
    • -Slot△(条件設定スロット):データベース登録済のスロット名がスロット番号、もしくは拡張子*.dbsrのパス名を指定して、検索条件を設定する
    • -NoDlg:検索ダイアログを開かずに実行する
    • -ClearParams:終了時、検索ダイアログの検索条件をクリアーする
  • [編集]-[編集]-[選択編集]-[選択アークセグメント移動](コマンド:MoveSelArcSeg)を追加。
    選択されたアークをセグメント単位で、連結するノード、アーク端点も連結して移動する。
  • [スタート]-[システム環境設定]-[ルックアンドフィール]で、「タッチパネルモード」チェックボックスを追加。
    これがONの場合は、リボンバーのボタンをやや広めの間隔で配置する。
  • [作図]-[アーク・ノード]-[曲線]で、(円、円弧などの曲線パラメーターのない)通常のアーク折れ線に関して、スプライン制御点をpcm.iniで調整できるようにした。
    [ARCSPFIT]
    REFPOS=n(nは処理番号=0〜5)
    • 0 = 従来通り
    • 1 = 補間点全点を制御点に
    • 2 = (概ね)補間点2点に1点を制御点に
    • 3 = (概ね)補間点3点に1点を制御点に
    • 4 = (概ね)補間点4点に1点を制御点に
    • 5 = (概ね)補間点5点に1点を制御点に
  • 文字の枠付け設定に関して、データベースの「フォント型」フィールドに「枠サイズ指定」を追加。
    従来、自動設定とpcm.iniファイルでのファクター指定のみ設定できたが、この設定により、各文字列データ毎に0.05mm単位で明示的に指定できる。

2019/10/11 [8.002]
  • Windows上での高DPI対応の流れとして、使用するフォントのデフォルトを、従来の「MS UI Gothic」から「Yu Gothic UI」に変更(正しくはSystemParametersInfo APIでSPI_GETNONCLIENTMETRICSを指定して返されるフォント情報からデフォルトのフォントとして使用する。Windows10では「Yu Gothic UI」が得られる)。
    新規レイヤーのフォントやメッセージウィンドウ、タスクバーなどで使われるフォントとして使用される。
  • [ツール]-[ネットワーク]-[ネットワーク解析]-[相互距離計算(直線距離)]において、「ロウ側基準点」に「アーク上最短距離」を追加。
    指定の計算ピッチでアーク上を走査して、起点からの最短距離になる場所での距離を求める。
  • 「プロジェクトワークスペース」で、「背景ピクチャー」の右ボタンポップアップメニューに「ピクチャー領域表示」を追加。
  • [スタート]-[システム環境設定]-[表示と印刷]で、「拡張グラフィックスを利用する」チェックON時の<詳細設定>-「アンチエイリアス効果(文字)」の設定に、「PC-MAPPING独自のアンチエイリアス処理」を追加(Windowsの環境によってアンチエイリアスが不十分な場合の代替処理)。
  • [画面表示]-[3DView]から表示される3Dビューウィンドウにおいて、3Dグリッドの表示機能を追加した([3D]-[表示]-[3Dグリッド])。
  • リボルバーカスタマイズのアクセラレータカスタマイズで、「ユーザーメニューから追加」ボタンを追加。
    リボンバーのカスタマイズ

2019/09/13 [8.001]
  • [ツール]-[UAVコース設計]-[オプション]-[UAV飛行計画コース 調整・出力]に関して、カメラの視野角度やレーザー走査角度をセットして、コースのフットプリント(撮影領域)を生成できるようにした。
  • 【選択セット(集合)】機能を追加([選択]-[集合演算]以下)
    • 現在の選択状態を名前つけて「選択セット(集合)」として格納する(実体は、内部属性データベースに格納、保存される)。
      必要に応じて、現在の選択状態に復元できる。
    • また、[選択]-[集合演算]-[セット演算]で、AND/OR/XOR/NOTの新しい選択集合を生成して、保存、現在の選択状態に反映することができる。
    • 当然ながら、選択状態を保存したあとに追加された要素に関しては反映されない。
  • 【標高メッシュ(TIN)間差分演算】
    [編集]-[標高メッシュ]-[編集]-[標高メッシュ(TIN)間差分演算]追加(コマンド:HMeshDiff)。
    演算対象のどちらかは標高メッシュであることが必要で、その範囲、解像度に合わせて演算処理結果の標高メッシュデータが生成される。
  • 【サーチバー】
    サーチバー(コマンド検索)を追加。
    メニュー名、コマンド、ツールチップなどに該当する文字列を検索してそのコマンドをリストして、実行する。
    なお、コマンドバーから「?? (検索文字列)」でも同様の検索ができる。
  • 【Google Mapsバーコード】
    [ツール]-[表示領域]-[Google Eatrh]-[Google Mapsバーコード]を追加(コマンド:GMBarcode)。
    現在表示されている表示中心付近をスマホなどのGoogle Mapsで表示するためのバーコードを表示する(従来コマンド:GmView△-BarCodeで対応していたものを、メニューとして独立させた)。
    ---
    《Ver.7.705》
    [ツール]-[表示領域検索]-[表示中心付近をGoogle Mapsで閲覧]に関して、コマンド:GmView△-BarCodeで、現在の位置を中心にGoogleMapsで見るためのURLを2次元バーコードで表記したものをブラウザで表示する。
    ---

    表示領域検索
  • 【背景イメージ・統合広域イメージをポリゴンで連続切り出し】
    [編集]-[編集]-[背景イメージ]-[背景イメージ・統合広域イメージをポリゴンで連続切り出し]を追加。
    レイヤーのポリゴン範囲の背景イメージ・統合広域イメージを連続して切り出し、ファイルに保存する。
  • 【アーク縦横断解析(標高メッシュ)】
    [ツール]-[図上計測]-[断面図・縦断図]-[アーク縦横断解析(標高メッシュ)]を追加(コマンド:CrossSecVH2)。
    選択されたアークに沿って、指定幅の横断解析を行い、アーク上の距離を縦軸、横断を横軸とした標高メッシュデータを生成する。
    元のアークも属性とともに転記される。
    UAVの飛行コース(Zは絶対値)で実行すれば、飛行コースを1次元的に見て周辺の地形情報を閲覧できる。
  • [ツール]-[標高メッシュ]-[フィルター・地形解析]の機能として
    • 最大傾斜度(pm)隣接4メッシュ
    • 最大傾斜度(pm)隣接8メッシュ
    を追加。
    傾斜度を「勾配率%」で出力する。
  • [ツール]-[標高メッシュ]-[段彩陰影図]-[傾斜方向ベクトルレイヤー生成]で、「隣接メッシュ比較で最大傾斜を求める」オプションを追加。
  • [エクスポート]-[Webタイル]-[Webメルカトルタイル画像]のダイアログボックスで、「前景レイヤーの選択ポリゴン矩形領域」オプションを追加。
    通常この処理ではまとめて大きな画像を作って、それから切り出す処理をしているので、あまり小さいポリゴン単位では、効率が低下する。
  • コマンド:VideoPlay2のオプションに、-Layer△(レイヤー名)を追加。
    指定のレイヤー(省略時は前景レイヤー)を対象として実行する。
    [システム]-[GPS]-[GPS]-[GPSログから軌跡ベクター生成]でGPSログから生成時、「VideoGo」フィールドの計算式に「-Layer△$LayerTitle」が自動的に付加されるようにした。
  • [システム]-[プロジェクト]-[プロジェクト]-[テンプレートマッチング]を追加。
    テンプレート(基準)となるプロジェクトを指定し、指定されたプロジェクトファイル(複数)を再構成する。