TOP > サポート > 機能更新履歴
 機能更新履歴

Ver.7.701〜
Ver.7.601〜Ver.7.609
Ver.7.510〜Ver.7.518
Ver.7.500〜Ver.7.502
Ver.7.450〜Ver.7.459
Ver.7.410〜Ver.7.414
Ver.7.401〜Ver.7.409
Ver.7.330〜Ver.7.332
Ver.7.320〜Ver.7.329
Ver.7.310〜Ver.7.319
Ver.7.301〜Ver.7.309
Ver.7.201〜Ver.7.229
Ver.7.001〜Ver.7.103
2017/06/29 [7.709]
  • イメージ:[図法変換]-[画像の図法変換]に関して、ダイアログボックスの設定で外部ファイル(TIFF・NAI)を複数指定して同時に変換できるようにした。
  • [作図]-[アーク作図・編集]-[円・円弧]での「3点指定の円弧作図(円周上の3点を指定)」において、既存の端点ノードにShiftキーでのスナップ、あるいは中ボタン(Ctrl+左ボタン)でのスナップした場合、そのアークを接線とする円弧を次の1点を指定することで作図する。
    中ボタンの場合は既存のアークと結合ノードを作って接続する。
  • [作図]-[アーク作図・編集]-[アーク追加(直線+円弧)](コマンド:ArcAddLineArc)を追加。
    直線と円弧作図をスペースキーによって切り替えで連続作図を実行する。
    また、直線から円弧への移行時はその直線を接線とする円弧を作図し、円弧から直線移行時はALTキーを併用することで円弧終端の接線方向に直線を作図する。
  • [ツール]-[UAVコース]-[UAV飛行計画コース CSV/AWN形式エクスポート](コマンド:ExportUAVCsv)を新設。
    UAVコース設計後、手編集したコースを(前景レイヤー)CSV/AWM形式に出力する。
  • [ツール]-[UAVコース]-[UAV飛行計画コース 反転](コマンド:UAVCourseInv)を新設。
    UAVコース設計後、飛行計画コースを反転させる。
  • [UAVコース設計]・[UAV撮影コース設計(レーザー点群)]ダイアログボックスで、
    • 連結後コースあたりの最大長をダイアログを出して、平均速度と滞空時間から算出できるようにした。
    • 撮影コースの方向に関して、現在値より90度単位で回転させるボタンを追加。
  • [編集]-[TINと標高メッシュ]での地理院地図標高タイルデータの取り込みに関して、DEM5(ZOOM=15)に対応した。
    DEM5Aを優先し、なければDEM5Bを取り込む。
  • 「ズームバー」に関して、マウス右ボタンメニューで、
    • 拡大率 X1 X2 X5 X10の指定
    • 十字マークのOn/Off
    • 距離ティックのOn/Off
    を選択できるようにした。
  • [ツール]-[断面図・縦断図]-[断面図作成プロパティ]で、ポイントクラウド上での断面図生成に対応した。
  • [印刷]-[整飾プロジェクトプレビュー]-[整飾プロジェクト印刷プレビュー設定]で、複数(最大4つまで)のプロジェクト(ベクタードキュメント)を整飾プロジェクトの指定のレイヤー枠に割り当てて表示、印刷できるようにした。
    また、縮尺を連動、比率指定連動、固定値を指定できるようにした。

2017/04/20 [7.708]
  • 表示モードからその内部に格納されている「レイヤー表示モード」を抹消する機能を追加。
    [プロジェクトエキスパート]-[表示モード]で、<現在のレイヤー表示モードを格納>ボタンを<レイヤー表示モードメニュー>ボタンに変更。
    このボタン押下で、
    • 選択表示モードに、現在のレイヤー表示モードを格納する
    • 選択表示モードからすべてのレイヤー表示モードを抹消する
    の2つのメニューを選択できる。
  • [印刷]-[矩形ポリゴン指定による連続印刷]に関して、従来は矩形ポリゴンのサイズ等から回転方向などを自動調整していたが、これに加えて、
    • 右周りポリゴンの第1点目を紙の左下にしての回転を想定する
    • 右周りポリゴンの第2点目を紙の左下にしての回転を想定する
    • 右周りポリゴンの第3点目を紙の左下にしての回転を想定する
    • 右周りポリゴンの第4点目を紙の左下にしての回転を想定する
    オプションを追加した。
  • [編集]-[レイヤー]-[ポリゴン3DView設定](コマンド:Pol3DView)を追加した。
  • [編集]-[レイヤー]-[注記3DView設定](コマンド:Text3DView)を追加した。
  • [印刷]-[整飾プロジェクトプレビュー]-[整飾プロジェクト印刷プレビュー設定]で、複数(最大3つまで)のプロジェクト(ベクタードキュメント)を整飾プロジェクトの指定のレイヤー枠に割り当てて表示、印刷できるようにした。

2017/03/14 [7.706]
  • 「印刷」のビットマップ出力、および、ウィンドウズ印刷の「仮想ビットマッププリンター」に、32ビットカラーでの背景透過もードを追加。
    この場合、[環境-1]のシステムパレットの背景塗りつぶし(紙色)ブラシのカラーを透過とする32ビット画像を生成する。
  • [編集]-[編集作図]-[アークをポイント位置へ伸縮]で、しきい値内のアークを全て伸縮するオプションを追加した。
  • [表示]-[ブックマーク]-[ブックマークの追加]にコマンドパラメーターを追加。
  • 整飾プロジェクトにおけるプレースホルダー文字列として、
    • %POS1X2D%
    • %POS1Y2D%
    経緯度の表現方法を「141°10′15.00″」になるものを追加した。
  • [プロジェクトエキスパート]-[背景プロジェクト]パネルに、「タイル画像取得、背景描画」を追加。
    地理院タイルと同形式の画像セットのURLやフォルダーを設定する事で、地理院地図と同様に背景表示可能。
  • [編集]-[編集作図]-[ポイントからアーク補間点移動・生成](コマンド:PntToVertex)を追加。
    指定レイヤーのポイント位置のしきい値ない補間点がなければ追加する。
    補間点位置はアーク上、もしくは、ポイント位置を指定できる。
  • [編集]-[レイヤー]-[矩形ポリゴンによる分割]で、ポリゴンの境界部分を閉じる、閉じないのオプションを追加。
  • [編集]-[Z値]-[TIN、標高メッシュからのZ値付与]で、TIN、標高メッシュと異なる座標系のレイヤーに対応した。
  • [選択]-[選択状態転記(レイヤー間)]で、異なる座標系のレイヤー間の転記に対応した。

2016/12/26 [7.705]
  • [編集]-[図法変換]-[経緯度座標からランベルト正角円錐図法へ変換]で、原点を明示的に指定できるようにし、その位置が仕上り紙面上の中央に配置されるようにした。
    また、「新規にプロジェクトを生成する」オプションを追加し、この場合、新しいレイヤーとして変換後のレイヤーが生成され、新しいプロジェクトに配置されるようにした。
  • [ツール]-[表示領域検索]-[表示中心付近をGoogle Mapsで閲覧]に関して、コマンド:GMView△-thで航空写真重ね合わせモードで表示されるようにした。
    表示領域検索
  • ベクター:[ツール]-[標高メッシュ効果・解析]-[傾斜量図](コマンド:BvView51)
    標高メッシュ:[効果]-[傾斜量図](コマンド:BvView51)
    を追加。
    いずれも、従来の"傾斜区分図(段彩図)"と類似するが、陰影処理、等高線付加機能はなく、計算方式として、Prewitt法とSobel法を明示して選択できるようにした。
    ※ただし、この機能を実行するには、あらかじめ構成標高メッシュを結合しておく事が必要。
  • [プロジェクトエキスパート]-[WMS/WMTS]パネルで、それぞれの設定で、アルファブレンドに加えて、乗算ブレンドのモードを追加した。
  • [選択]-[選択ベクター(前景レイヤー)のみ表示](コマンド:HideUnSelF)を追加。
    前景レイヤーのみ「選択ベクターのみ表示」となる。
  • [属性フィールドの設定]ダイアログボックスで、「入力禁止(表示のみ)」チェックボックスを追加。
    ONの場合、このフィールドのデータを属性照会や属性ウィンドウ上で直接キーボードからの入力を抑制する。
  • [ツール]-[表示領域検索]-[表示中心付近をGoogle Mapsで閲覧]に関して、コマンド:GmView△-BarCodeで、現在の位置を中心にGoogleMapsで見るためのURLを2次元バーコードで表記したものをブラウザで表示する。
    表示領域検索
  • メニューにないコマンド:ImportEVMapを追加。
    環境省1/25,000植生図GISデータを、ZIPファイルを直接解凍してインポートする。
    また、フィールド名も日本語に変更し、整数型になるフィールドは整数型にセットする。
    1/2.5万植生図GISデータ [環境省生物多様性センター]

2016/09/07 [7.704]
  • [ツール]-[想定整形地の生成]-[想定整形地の生成(一括処理)]で、新規に生成される想定整形地レイヤーのポリゴンタイプを必ず1アーク1ポリゴンになるように調整した。
    想定整形地の生成 [一括処理]
  • HTML記法で、従来、
    font size=NNNで、NNN=1,2,3,4,5,6,7が8、10、12、14、18、24、36論理ポイントに対応する

    font size=NNNxxで、
    • NNN = 数値
    • xx = 単位(px:ピクセル/in:インチ/cm:センチ/mm:ミリ/pt:ポイント/%も指定可)
    などが指定できるようにした。
    また、単位なしの場合、NNN=1,2,3,4,5,6,7,8,9,10が8、10、12、14、18、24、36、48、64、96論理ポイントに対応する。
    【属性表示】属性のHTML記法
  • [印刷]-[表示領域を現在の印刷枠に移動](コマンド:PrintViewArea)を追加。
  • [ツール]-[空間統計解析]-[ポリゴンランダムフィル(4色定理)](コマンド:PolFCFill)を追加。
    アークを共有する隣接ポリゴンが同色にならないように振り分ける(※構造化ポリゴンである事が必須)。
    数学理論上4色あれば振り分け可能だが、実装上最低でも5〜6色程度は使用される。
    また、コマンド:PolFCFill△-MaxCol△nnで使用する色数(=n)を指定する事も可能。
  • ポリゴンの属性表示に関して、レイヤーのキーリストに@PolAttrCPos = 2をセットする事で、そのポリゴンに中心点があって、表示範囲内にその中心点があれば中心点位置に、なければ表示されているポリゴン内の適当な位置に表示されるようにした。
    また、1つのポリゴンが複数に分割されて表示されるケースでは、それらの全ての(分割された)ポリゴンに属性が表示されるようにもした。
  • [作図]-[スナップ設定]で、「スナップ情報をツールチップ表示する」チェックを追加。
    ONの場合、スナップしたレイヤー名やどの要素にスナップしたかの情報を表示する。
  • [ツール]-[空間統計解析]-[ポリゴン包含ポイント集計]で、
    • 包含ポイントの指定属性値ごとにポイント数を集計し、ポリゴン属性にセットする
    • 包含するポリゴンの指定属性値ごとにポイント属性にセットする
    を追加。
  • [印刷]-[矩形ポリゴン指定による連続印刷]で、「ユニオン(あれば)単位で」のチェックを追加。
    これがONの場合、ポリゴンのユニオン単位に出力される。
    図葉メッシュ単位に印刷する(矩形印刷)
  • データベース:[編集]-[座標データ]-[座標データのショートベクター変換]で、「(ショートベクターではなく)左下、右上の矩形ポリゴンを生成する」オプションを追加。
    始点、終点を左下、右上と読み替えて矩形のポリゴンを生成する。
  • [ツール]-[画像ファイル]-[矩形ポリゴンから画像図郭座標付与](コマンド:TouchGeoTiff)を追加。
    ポリゴンの内部属性に画像ファイルへのパス設定があれば、ポリゴンの矩形領域をその画像の図郭情報として、GeoTiffファイルやワールドファイルとして保存する。

2016/06/30 [7.703]
  • [ツール]-[空間統計解析]-[ポリゴンオーバーレイによる面積クロス集計]で、「ラスターピクセル計数方式で処理する」オプションを追加。
    解像度を指定して内部的に画像を生成し、その合成ピクセルをカウントして面積クロス集計を実行する。
    指定される解像度までに限定されるが、ポリゴンオーバーレイによる構造的エラーによる集計エラーを回避でき、また、一般に高速な処理が期待できる。
  • [プロジェクトエキスパート]-[署名と権限]パネルに、「外部ファイルを相対パスで保存」チェックを追加。
    プロジェクト保存時に、外部ファイルのパス名をプロジェクトファイルからの相対パスにして管理する。
    これらは読み込み時に絶対パスに変換されて、取り込まれ再度プロジェクト保存時まで絶対パスで管理される。
  • [印刷]-[矩形ポリゴン指定による連続印刷]で、 ポリゴンのフィールドに縮尺分母を入力しておき、その縮尺に合わせて印刷できる機能を追加。
    • 「(矩形でなく)任意のポリゴン領域を印刷する」チェックボックス=ON
    • 「印刷設定での縮尺で印刷する」チェックボックス=OFF
    • 「ポリゴン属性で縮尺を個別指定」ドロップダウンリストから縮尺分母を入力したフィールドを選択
    して実行する。
    その際、ポリゴン内部属性に「@Scale範囲Check」フィールドがあれば、印刷領域とポリゴン領域の比を計算し、100分率で格納するようにした。
    図葉メッシュ単位に印刷する(矩形印刷)
  • [編集]-[編集作図]-[アーク平滑化]で、「指定より短いセグメントの補間点を削除」する際、「これ以下の夾角では対象外」のオプションを追加。
    これを0にすると、夾角判定をしない。
  • データベース:[編集]-[演算、集計、分析]-[クロス集計](コマンド:DbCalcCross)を追加。
    ロウ側になるフィールド、カラム側になるフィールド、演算するフィールド、集計方法などを指定して集計した表(データベース)を生成する。
  • [設定]-[地理院タイル等表示設定]で、「拡大・縮小時の視覚効果」チェックを追加した。
    ※地理院地図以外に広域イメージ等で画像を重ね合わせている場合や地理院地図自体を多重に重ね合わせている場合は使用できない(画像が乱れる)事がある。
    【地理院地図】地理院タイル(旧電子国土Webシステム背景画像)等表示機能
  • [ファイル]-[システムツール]-[イメージ変換]-[イメージの統合・再構成]で、変則図郭の画像にも対応した。

2016/04/01 [7.702]
  • イメージの重ね合わせ表示に関して、従来のアルファブレンドに追加して「乗算ブレンド」を追加。
    「レイヤーの背景イメージ」・「背景ピクチャー(画像)」・「広域イメージ」・「標高メッシュの段彩陰影図」に関しても対応した。
  • データベース:[編集]-[文字列変換]で、変換方法に
    • 絶対パスを相対パスに
    • 相対パスを絶対パスに
    を追加。
    そのDBのパス、あるいは、そのDBを内部属性に持つレイヤーのパス、あるいは、そのDBを含むプロジェクトのパスが参照される。
  • 広域イメージ、背景ピクチャー、レイヤー背景イメージで、透過色に対し、その近傍色も透過させる機能を追加。
    各設定で、その「近傍度合」を1〜10(大きい方がより離れた色でも透過する)で指定する。
  • [ファイル]-[システムツール]-[イメージ変換]-[統合広域イメージの生成]で、白透過色に対し、その近傍色も透過させる機能を追加。
    [統合広域イメージの作成]ダイアログボックスで、「透過白色近傍レベル」を1〜10(大きい方がより離れた色でも透過する)で指定する。
    統合広域イメージ機構
  • [設定]-[地理院タイル等表示設定]からの詳細設定で、1つのズームレベルに複数の種別タイルを指定できるようにした。
    また、地理院地図の表示に関して、ブレンド(乗算ブレンド、アルファブレンド)を指定できるようにした。
    地理院タイル(旧電子国土Webシステム背景画像)等表示機能
  • PVP(プレゼンテーションビューアーパック)の生成に関して、「プロジェクトデータを別ファイル(拡張子*.pvp)に分離して出力する」オプションを追加した。
    これにより、論理的には2GBを超えるプロジェクトデータに関しても処理可能となる(実用上は64ビット版が必要)。
    プレゼンテーションビューアパック
  • [プロジェクトエキスパート]-[背景プロジェクト]パネルからの背景プロジェクトの設定で、「指定オーダーで表示する」オプションを追加。
    表示モードの「描画順位カスタマイズ」で追加された「背景プロジェクト(オーダー指定)」の順位でまとめて描画されるようにした。

2016/04/01 [7.701]
  • 【PC-MAPPING Ver.7.7がリリースされました】
    システム構成に一部変更があり、そのため、PC-MAPPINGからの「最新版の検索」メニューでは、現行PC-MAPPING Ver.7.6xxからVer.7.7xxへの(自動)更新はできません。
    お手数ですが、最初の1回は最新版ダウンロードページからアップグレードをお願いいたします。
    最新版ダウンロード PC-MAPPING Ver.7